Browsing this Thread:   1 Anonymous Users



Bottom   Previous Topic   Next Topic  Register To Post



pitombeira #1 [Resolvido] Servidor X com problemas
Bom dia,

Eu estou utilizano o Mint 18 Sarah Cinnamon, e fui tentar configurar o fstab para ele mapear automaticamente algumas pastas na rede, fiz todo a montagem direito e quando reinicei para testar, o servidor X comecou a dar problema, conectei pelo pen drive, modifiquei a linha no fstab, porem o problema no servidor X continua.

ps1.: Meu primeiro erro, foi de ter modificado o fstab e nao ter feito backup.

ps2.: Essa maquina ja tinha configurado o samba acessando o AD.
ps3.: Verifiquei o Sys log que me infora a seguinte mensagem;

mdm.service: failed at step EXEC spawning /usr/sbin/mdm-stop: No such file or directory
(achei o seguinte link com o bug https://forums.linuxmint.com/viewtopic.php?t=226835 )

Porém eu não consegui editar o arquivo como ele fala na solução.

consegui abrir o modo gráfico na mão, com o seguinte comando
$ /usr/sbin/mdm

mas o erro não foi sanado
alguem poderia me ajudar ??
Posted on: 25/10/2016 9:32

Edited by pitombeira on 26/10/2016 13:19:43
Reason: Resolvido


Wellington #2 Re: Servidor X com problemas

Já que o arquivo não existe tenta criar

sudo ln -s /dev/nul/ /usr/sbin/mdm-stop

sudo ln -s /dev/nul/ /usr/sbin/mdm-restart

se não der certo apenas remova-os

sudo rm /usr/sbin/mdm-stop /usr/sbin/mdm-restart

Posted on: 25/10/2016 14:21

Notebook Avell B153 SE Plus
Linux Mint 18 - Sarah - Cinnamon AMD64
Kernel 4.8.5-heiradi
Intel Core i5 Haswell
8GB RAM
Nvidia GeForce GT 730M

Steam welblade


pitombeira #3 Re: Servidor X com problemas
Não solucionou Wellington, para reiniciar o modo gŕafico eu tenho que fazer o

$ sudo mount -o remount,rw /
e depois

$ sudo /usr/sbin/mdm

não vi nada no syslog que podesse me chamar atenção. e o sobre os arquivos não aparece mais.
Posted on: 25/10/2016 16:16


Wellington #4 Re: Servidor X com problemas
posta aí o seu fstab pra dar uma olhada
Posted on: 25/10/2016 17:04

Notebook Avell B153 SE Plus
Linux Mint 18 - Sarah - Cinnamon AMD64
Kernel 4.8.5-heiradi
Intel Core i5 Haswell
8GB RAM
Nvidia GeForce GT 730M

Steam welblade


pitombeira #5 Re: Servidor X com problemas
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda11 during installation
# /boot/efi was on /dev/sda1 during installation
UUID=FA23-3F7E /boot/efi vfat umask=0077 0 1
# /home was on /dev/sda8 during installation
UUID=25bed34d-6617-4ccd-828a-c0554f291bfd /home ext4 defaults 0 2
# swap was on /dev/sda10 during installation
UUID=1606f491-4080-4d60-b3bc-bb6eea04951d none swap sw 0 0
# swap was on /dev/sda12 during installation
UUID=e0359c7f-df35-496b-a531-7d2c03994d13 none swap sw 0 0
# swap was on /dev/sda9 during installation
UUID=0e97aa0f-e627-4635-8b1f-c02bdb647d0e none swap sw 0 0
Posted on: 25/10/2016 17:12


Wellington #6 Re: Servidor X com problemas
1 - O que você modificou?
2 - faça o comando blkid no terminal e cole a saída aqui.
3 - Por que exatamente você te 3 partições swap?
Posted on: 25/10/2016 17:15

Notebook Avell B153 SE Plus
Linux Mint 18 - Sarah - Cinnamon AMD64
Kernel 4.8.5-heiradi
Intel Core i5 Haswell
8GB RAM
Nvidia GeForce GT 730M

Steam welblade


pitombeira #7 Re: Servidor X com problemas
Citando:

Wellington wrote:
1 - O que você modificou?
2 - faça o comando blkid no terminal e cole a saída aqui.
3 - Por que exatamente você te 3 partições swap?



1 -> A modificação eu apaguei, eu tinha montado uma pasta na área de trabalho para conectar a minha pasta compartilhada no servidor win.
2-> /dev/sda1: LABEL="ESP" UUID="FA23-3F7E" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="6c955c87-d74f-46ff-985c-ed2a75279125"
/dev/sda2: LABEL="DIAGS" UUID="4057-5EFC" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="772c347b-3e0c-4606-a7be-b43ca43c8fa3"
/dev/sda4: LABEL="WINRETOOLS" UUID="A0B65909B658E178" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="f28081fc-4956-4281-a852-297975f0aeee"
/dev/sda5: LABEL="OS" UUID="321C5D901C5D5049" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="445483f3-e6b9-4b22-b2eb-cd095ef2c05e"
/dev/sda6: UUID="C852E0EC52E0E064" TYPE="ntfs" PARTUUID="265d0105-b234-4659-9ea5-e32736050b43"
/dev/sda7: LABEL="PBR Image" UUID="F8D8A7A0D8A75C1E" TYPE="ntfs" PARTLABEL="Microsoft recovery partition" PARTUUID="35e6a0a0-95e1-4b93-a2a9-a6e15b6119e8"
/dev/sda8: UUID="25bed34d-6617-4ccd-828a-c0554f291bfd" TYPE="ext4" PARTUUID="9b781ffc-dc27-46d1-bb76-703070020b52"
/dev/sda9: UUID="0e97aa0f-e627-4635-8b1f-c02bdb647d0e" TYPE="swap" PARTUUID="adfe9dc6-99d7-447f-b865-bcf3b233bb88"
/dev/sda10: UUID="1606f491-4080-4d60-b3bc-bb6eea04951d" TYPE="swap" PARTUUID="1ba3bcce-18f9-4780-bb8c-3660741a872b"
/dev/sda11: UUID="e64d4c3b-0f97-4cbe-8b7a-22e836e1a93c" TYPE="ext4" PARTUUID="14f3eb34-54d4-403a-b7d6-c725d5bbe3d6"
/dev/sda12: UUID="e0359c7f-df35-496b-a531-7d2c03994d13" TYPE="swap" PARTUUID="9925b737-c2a0-49e2-8313-3ce4c16b0eaf"
/dev/sda13: UUID="ed89fba9-7d44-4062-9e40-49f273cd250c" TYPE="ext4" PARTUUID="4d17c873-9391-449f-b458-01810a8d32bb"


3-> Tenho o Win 10, instalei o Ubuntu e depois o Mint, ainda não configurei o Hd corretamente, fui testando o Mint para migrar e comecei a usar e ainda não configurei o HD de forma correta. estou cheio de partições nele. Pelo o que entendi que o comando BLKID são elas né? tenho essa bagunça toda.
Posted on: 25/10/2016 17:44


Wellington #8 Re: Servidor X com problemas
Você apagou a linha que monta "/"

abaixo você vai ver o arquivo corrigido

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda11 during installation
UUID=e64d4c3b-0f97-4cbe-8b7a-22e836e1a93c / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sda1 during installation
UUID=FA23-3F7E /boot/efi vfat umask=0077 0 1
# /home was on /dev/sda8 during installation
UUID=25bed34d-6617-4ccd-828a-c0554f291bfd /home ext4 defaults 0 2
# swap was on /dev/sda10 during installation
UUID=1606f491-4080-4d60-b3bc-bb6eea04951d none swap sw 0 0
# swap was on /dev/sda12 during installation
UUID=e0359c7f-df35-496b-a531-7d2c03994d13 none swap sw 0 0
# swap was on /dev/sda9 during installation
UUID=0e97aa0f-e627-4635-8b1f-c02bdb647d0e none swap sw 0 0
Posted on: 25/10/2016 18:01

Notebook Avell B153 SE Plus
Linux Mint 18 - Sarah - Cinnamon AMD64
Kernel 4.8.5-heiradi
Intel Core i5 Haswell
8GB RAM
Nvidia GeForce GT 730M

Steam welblade


Wellington #9 Re: Servidor X com problemas
Realmente você tem 3 swaps o senhor é um fanfarrão
Posted on: 25/10/2016 18:02

Notebook Avell B153 SE Plus
Linux Mint 18 - Sarah - Cinnamon AMD64
Kernel 4.8.5-heiradi
Intel Core i5 Haswell
8GB RAM
Nvidia GeForce GT 730M

Steam welblade


pitombeira #10 Re: Servidor X com problemas
Citando:

Wellington wrote:
Você apagou a linha que monta "/"

abaixo você vai ver o arquivo corrigido

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda11 during installation
UUID=e64d4c3b-0f97-4cbe-8b7a-22e836e1a93c / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sda1 during installation
UUID=FA23-3F7E /boot/efi vfat umask=0077 0 1
# /home was on /dev/sda8 during installation
UUID=25bed34d-6617-4ccd-828a-c0554f291bfd /home ext4 defaults 0 2
# swap was on /dev/sda10 during installation
UUID=1606f491-4080-4d60-b3bc-bb6eea04951d none swap sw 0 0
# swap was on /dev/sda12 during installation
UUID=e0359c7f-df35-496b-a531-7d2c03994d13 none swap sw 0 0
# swap was on /dev/sda9 during installation
UUID=0e97aa0f-e627-4635-8b1f-c02bdb647d0e none swap sw 0 0


Cara, deu muito certo! fico bastante agradecido! primeira vez que utilizo o forum da comunidade e fui muito bem atendido! Obrigado Wellington ! vou estudar um pouco mais sobre o MINT e poder ajudar a comunidade também.
Posted on: 26/10/2016 13:19







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.

[Advanced Search]