Browsing this Thread:   1 Anonymous Users



Bottom   Previous Topic   Next Topic  Register To Post



Álvaro #1 Comandos para "?" e "/" não funcionam
Atualmente uso o Linux Mint 17.1, migrei a pouco tempo, porém um dos problemas que me vem atormentado por pouco mais de uma semana é o teclado.
Aparentemente, o sistema não está reconhecendo os comandos usados pelo meu teclado para imprimir as teclas "?" e "/", e esses são de extrema importancia para mim, pois sem eles fica dificil usar o terminal, entre outras coisas como programar.
Já procurei em foruns e em vários sites, porém nenhum deles me mostrou algum jeito de realmente fazer meu sistema reconhecer essas teclas.
Gostaria de saber se álguem por aqui sabe como resolver isso. Desde já agradeço quem opinar nesse tópico afim de me ajudar a resolver esse problema.

PS: Eu não digitei as teclas "?" e "/" nesse tópico, apenas dei um Ctrl+C e Ctrl+V em alguns textos que tenho aqui.
Posted on: 23/2/2015 17:47


Francis #2 Re: Comandos para "?" e "/" não funcionam
Seu teclado é Layout de Teclado Brasileiro ABNT2?

Na hora da instalação você conferiu se as teclas " ? / " estavam funcionado corretamente?

Veja essa dica aqui que temos na nossa Wiki.

http://www.linuxmint.com.br/modules/d ... i/reconfigurando_a_locale

Deve te ajudar.
Posted on: 23/2/2015 19:52

_MSC_CLICK_TO_OPEN_IMAGE
_MSC_CLICK_TO_OPEN_IMAGE


Álvaro #3 Re: Comandos para "?" e "/" não funcionam
Francis, já tentei fazer fazer os comandos que tem lá, porém apareceu um erro:
"Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-37-generic
Warning: No support for locale: pt_BR.utf8"

O layout do teclado do meu notebook é ABNT2 (Brasileiro) e ele está atualmente no sistema, nas configurações do teclado, como Portuguese(Brazil).
Posted on: 24/2/2015 14:11


Francis #4 Re: Comandos para "?" e "/" não funcionam
Citando:

Álvaro wrote:
Francis, já tentei fazer fazer os comandos que tem lá, porém apareceu um erro:
"Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-37-generic
Warning: No support for locale: pt_BR.utf8"

O layout do teclado do meu notebook é ABNT2 (Brasileiro) e ele está atualmente no sistema, nas configurações do teclado, como Portuguese(Brazil).
Qual foi o comando que resultou nesse erro?
Posted on: 24/2/2015 22:13

_MSC_CLICK_TO_OPEN_IMAGE
_MSC_CLICK_TO_OPEN_IMAGE


Álvaro #5 Re: Comandos para "?" e "/" não funcionam
sudo dpkg-reconfigure keyboard-configuration
Posted on: 26/2/2015 15:56


Francis #6 Re: Comandos para "?" e "/" não funcionam
Citando:

Álvaro wrote:
sudo dpkg-reconfigure keyboard-configuration


Tenta novamente tem que aparecer uma tela assim.
_MSC_CLICK_TO_OPEN_IMAGE


Nela você configura seu teclado.
Posted on: 26/2/2015 16:44

_MSC_CLICK_TO_OPEN_IMAGE
_MSC_CLICK_TO_OPEN_IMAGE


Álvaro #7 Re: Comandos para "?" e "/" não funcionam
Já arrumei. As teclas convencionais continuam sem pegar, mas só preciso segurar "Alt Gr" e apertar o "Q" ou "W" para sair, respectivamente, / ou ?. Obg pela ajuda de todos o/
Posted on: 10/3/2016 11:51


Alexandre Quintela #8 Re: Comandos para "?" e "/" não funcionam
Isso está relacionado ao modelo do teclado e não à configuração errada. No meu netbook Asus, por exemplo, o modelo do teclado põe o sinal de ? na mesma tecla do W, precisando que segure Alt Gr para acionar o sinal de interrogação. Já a / pode ser acionada se pressionar a tecla Fn e a tecla 0 ou Alt Gr e Q. Ou seja, não importa se uso Linux ou Windows, neste modelo de teclado sempre precisarei acionar estas combinações de teclas para por os respectivos sinais. Semelhante ao fato de termos que segurar Shift para por um acento ou uma letra maiúscula.
Posted on: 10/3/2016 12:34

Ultrabook: Acer Aspire M5 - Intel Core i5 - 6Gb RAM - 500Gb HD - 20Gb SSD - Linux Mint 18 Xfce
Netbook: Asus EeePC 1025C 10.1' - Intel Atom N2600 - 2Gb RAM - 320Gb HD - Linux Mint 18 Xfce
Twitter: @PonteAlexandre


qxada07 #9 Re: Comandos para "?" e "/" não funcionam
Este problema acontece principalmente quem possui o note ThinkPad...

Para solucionar este problema deve editar o arquivo "/etc/default/keyboard" e realizar as alterações abaixo:

XKBMODEL="thinkpad60"
XKBLAYOUT="br"

Para validar a configura sugiro que você de um boot no linux.

Posted on: 20/9/2016 10:38


Marcelo Alves #10 Re: Comandos para "?" e "/" não funcionam
Citando:

qxada07 wrote:
Este problema acontece principalmente quem possui o note ThinkPad...

Para solucionar este problema deve editar o arquivo "/etc/default/keyboard" e realizar as alterações abaixo:

XKBMODEL="thinkpad60"
XKBLAYOUT="br"

Para validar a configura sugiro que você de um boot no linux.

Nossa... Este já é um tópico até antigo... Mas valeu pela dica! Certamente será útil.

Fique com Deus.
Posted on: 20/9/2016 22:39

:: João 3,16 ::
Recomendações da Administração
Como usar o Fórum
Doe mais que seu tempo!







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.

[Advanced Search]