[Resolvido] Instalação do FlatCAM

Boa tarde galera! Tudo bem com vcs?
Estou tentando instalar o programa FlatCAM mas esse erro aparece e eu nunca vi antes, apesar de mísera experiência com Linux:

Could not find a version that satisfies the requirement PyQt5 (from flatcam) (from versions: )
No matching distribution found for PyQt5 (from flatcam)

Alguém usa esse programa por aqui? Ou alguém sabe o que pode ser esse erro?

Meu sistema:
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=19.2
DISTRIB_CODENAME=tina
DISTRIB_DESCRIPTION="Linux Mint 19.2 Tina"
NAME="Linux Mint"
VERSION="19.2 (Tina)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 19.2"
VERSION_ID="19.2"
HOME_URL="https://www.linuxmint.com/"
SUPPORT_URL="https://forums.ubuntu.com/"
BUG_REPORT_URL="http://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/"
PRIVACY_POLICY_URL="https://www.linuxmint.com/"
VERSION_CODENAME=tina
UBUNTU_CODENAME=bionic
cat: /etc/upstream-release: É um diretório

Obrigado.
Post edited by Alquintela on
·

Comentários

  • Como vc esta tentando instalar? pacote .deb, apt-get etc.

    Instala o python-pyqt5 pelo synaptic e depois tenta instalar o flatcam novamente.

    No site deles tem instruções para outras formas de instalação, como clonar o repositório(não sei como funciona essa questão de clonagem), olha lá os requerimentos também se o python-pyqt5 não resolver.
    ·
  • Fala luiz99,
    tentei usar o seguinte comando para instalar: pip install flatcam
    de acordo com o site PyPi https://pypi.org/project/flatcam/
    Instalei o pyqt5 pelo Synaptic mas o erro continuou

    Baixei o zip do repositório deles mas quando executo o FlatCAM.py nao acontece nada. É preciso fazer algo mais? Obrigado
    ·
  • quando tento abrir pela linha de comando
    [email protected]:~/FlatCAM$ python FlatCAM.py
    Traceback (most recent call last):
    File "FlatCAM.py", line 6, in
    from FlatCAMApp import App
    File "/home/papo/FlatCAM/FlatCAMApp.py", line 1848
    SyntaxError: Non-ASCII character '\xc2' in file /home/papo/FlatCAM/FlatCAMApp.py on line 1848, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details
    ·
  • Aparentemente consegui instalar e executar o FlatCAM! Depois de inúmeras tentativas tive sucesso. Mas o que eu ainda não entendo é pq existem n comandos para instalar pacotes (apt-get, pip, git, etc.) Qual a diferença entre eles? Eu venho do windows e nao tenho muita experiencia com linux. To aprendendo
    ·
  • Acredito que o pip é um instalador interno do python, então vários programas relacionados ao python usam esse comando, realmente tem várias opções, mas tente começar pela central de programas que é extremamente simples, só usando ela vc nem sentirá falta do apt-get e synaptic, quando baixar pacotes .deb é só clicar duas vezes e pedir para instalar, quando é pacote tipo esse do flatcam, tar.gz etc o negocio complica, tem que extrair e ver se tem alguma instrução no pacote senão tem que ir atrás de tutorial.
    ·
  • Sempre relate como conseguiu resolver o problema, porque terão outros que vão pesquisar seu tópico futuramente.
    ·
Entre ou Registre-se para fazer um comentário.